Guide to Creating, Compiling, and Running a Windows 32 Console Application Using
Microsoft Visual C++ Express Edition

BJ Furman

170CT2009

Condensed written instructions from: Creating a Standard C++ Program (C++) Help File (from:

http://msdn.microsoft.com/en-us/library/ms235629%28VS.80%29.aspx)

To create a new project and add a source file:

1.

Create a new project:

On the File menu, point to New, and then click Project....

From the Visual C++ project types, click Win32, and then click Win32 Console Application.
Enter a project name.

By default, the solution that contains the project has the same name as the new project, but you can enter a
different name. You can enter a different location for the project if you want.

Click OK to create the new project.

In the Win32 Application Wizard, select Empty Project and click Finish.

If Solution Explorer is not visible, click Solution Explorer on the View menu.

Add a new source file to the project:
0 Right-click on the Source Files folder in Solution Explorer, point to Add, and click New Item.
0 Click C++ File (.cpp) from the Code node, enter a file name, and then click Add.

The .cpp file appears in the Source Files folder in Solution Explorer and a tabbed window appears where
you type in the code.

Click in the newly created tab in Visual Studio and type a valid C++ program that uses the Standard C++
Library, or copy and paste one of the sample programs.

For example, you can use the set::find (STL Samples) sample program in the Standard Template Library
Samples topics in the help.

If you use the sample program for this procedure, notice the using namespace std; directive. This directive

allows the program to use cout and endl without requiring fully qualified names (std::cout and std::endl).

On the Build menu, click Build Solution.

The Output window displays information about the compilation progress, such as the location of the build
log and a message that indicates the build status.

On the Debug menu, click Start without Debugging.

If you used the sample program, a command window is displayed that shows whether certain integers are
found in the set.
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Instructions and screen shots from Creating a Standard C++ Program (C++) Help File

1. Figure 1: Creating a new project. To create a new project:

On the File menu, point to New, and then click Project....
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To create a new project and add a source file
1. Creabe a new praject:
On the File menu, point to New, and then dick Project....
2. From the Visual C+# project types, chek WIR32, and then click Win32 Console Application.
* ::‘l::‘filﬁ?::‘: ::xnn that cantains the project has the same name as the New project, but you can anter o &4
You can enter a differant location for the project f you want.
Click OK to create the new project.
4, Inthe Win32 Application Wizard, sclect Enpty Project and click Finish.
5. I Schstson Explores i3 not wissble, chek Solution Explorer on the View menu.
6. Add a new source file to the project:
» Right-chck on the Source Files folder in Solution Explorer, point to Add, and click New Ttem.
& Chok C++ File (.opp) from the Code node, enter a fle name, and then dick Add.
The .cpp file appears in the Source Filas folder in Solution Explarer and a tabbad window appasre where you tyf
7. Chick m the newly created tab in Visual Studio and type 2 vald Cée program that uses the Standard Coe Libran
paste one of the sample programs.
Im_.—;nm you can use the gat-:find (STL Samgles) eample program in the Standard Template Library Sampl
If you use the sample program for thes procedure, notice the using snamespace std: directive. This drective al
program to use cout and endl without reguiring fully qualified names {std::cout and std:zendl).
£ Onthe Build menu, dick Build Solution.
The Ouloul window digplavs information abot the comdabon progress, sush 35 the lacation of the buid fog ar
that indicates the buld st
5. On the Debusg menu, (Irric Start without Debugaing.
1f you wsed the samele program, 3 command windaw s duplaved that shows whether certain mntegers are fown] | |- .
= Next Steps
Output o
Previous: Craating Commang-Ling Apglications (C+-+1 | Next: Compang 3 Nate Ce+ Program from the Command) o i L@ =
= See Also
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Visual C» Guided Tour
* i
4!(:- BL. (=M Other Resources
Ready
Figure 1. Create a New Project. From the File menu, select: New | Project
2. Figure 2: Starting a Win32 Console Application. From the Visual C++ project types, click Win32, and then
click Win32 Console Application.
3. Enter a project name.
By default, the solution that contains the project has the same name as the new project, but you can enter a
different name. You can enter a different location for the project if you want.
Click OK to create the new project.
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Figure 2. Select Project Type. Choose the Win32 Console Application from the list of
templates. Enter a project name and location.

4. Figure 3: Completing the empty project. In the Win32 Application Wizard, select Empty Project and click

Finish.

1™ Creating a Standard C++ Program (C+4) - Microsoft Visual Studio 2008 Documentation - Microzoft Documaent Explors & su.n Page - Visual C++ 2008 Express Edition
Fle Ede Vew Toos Window  Help Fle EdE Vew Toos Wndow Help

D (07 [ a A How Dol » O Search | index f connerns T vep Favortes | ] 7 ) %) Msom Farume TR R 2% N - T R, N I e < P ) - o2
Conternts = 9 X Creating a Sta...+ Program (C++)

F1 Optionss (chocse) = URL: ritg-hip M VECT VIO MS. Msdnexpress.vs
Culunﬂ::\l ~ W Code: 2 .

3 1sual C++2008
Express Edition

Creating a Standard C++ Program (C++)
Sseales Send Feadback

= Prerequisites

These Lopics assume that vou understand the fundamentals of the Ces language. lh-ou dr:]ll! g,
wnmmumdw “Ct+ Deginner's Guide,” written by Herb Schidt, avalable anfine ot

Cverview Agplication type: Add comimen header files for:

To create a new project and add a source file 141 Cgracie spplication
1. Create 3 new project: i

On the File menu, pent to New, and then dick Project... =
2. Froe the Visual Co+ project types, cick Win32, and then dick Win32 Consale Application. L1 gtanic bwary
3. Enter a project name. :

By datault, tha soiution that coNtains the Drojact Ras the £3ms namea 35 the new praject, but you can of A pors:
‘ou can enter 3 diferent location for the project & you wank. B Emply projoct
Chck OK to create the new project %
1n the win32 Application Wizard, select Empty Project and cdick Fimish. Thas option creates a vepre) e based on the groject
1 Sehuteon Explorer s not visble, dok Sobution Explorer on the View menu, " [name you speciied but adds no fles to & Use this when
& Afd 3 new sourte file o the project: mtend to al your ovn source fies.

® Right-chck on the Source Files lolder in Solution Explarer, point to Add. and dick Mew ltem.

® Chek C4+ File {.cpp) From the Code node, enter & fle name, and then chok Add,

The .cpp file appears ) tha Source Fles folder in Soiution Explocer and 3 taibed window appears wher
7. Chick in the newly created tab in \'lw.il Studio and type 3 valid Cos program that uses the Standard Ce.

paste ane of the sampée program:

Fur example, you can use the ::s.jnd_a_l...nznn]ulumpit program i the Standard Template Libra

oo

:rm wae the samgle program for thes procedure, notice the using nazespace 2:d; directive. This dif
pragram to use cout and endl without requinng fully gualified names (std:icout and std:zendl),
@ Onthe Rulld man, chc Build Solution.
winddow displays about the pragrass, such as the location of tha bul
that indicates the bugd status,
9. Onthe Debug menu, dck Start without Debugging.
1F you used the sampbe program, 3 command window i displaved that shows whether certain integers [=# l = [Fnen ][ ]

Next Steps —-
~ex

Previous: Cragting Command-Ling Applictions (G2 | Wext: Compling 3 Nativs G Procram from the Command shy, sutput from: =

- See Also

Tasks

Vil Cee Gusdad Tour
T3 Code Definbion Window (3 Cal Brovwser | 3 Qutput |
Creatng peoject Frst_Project’...

At |Em. Other Resources

Figure 3. Win32 Application Wizard. Choose, ‘Empty Project’, then Finish.
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5. Figure 4: Making Solution Explorer visible. If Solution Explorer is not visible, click Solution Explorer on
the View menu.
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Figure 4. Solution Explorer. If not opened, go to the View menu, and click on Solution
Explorer. This will allow you to see the source files associated with your program.
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6. Figures 5 and 6: Adding a new source file to the project:

o0 Right-click on the Source Files folder in Solution Explorer, point to Add, and click New Item.
0 Click C++ File (.cpp) from the Code node, enter a file name, and then click Add.
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Figure 5. Adding a New Source File to the Project. Your project will consist of various source
(.c files) and header (.h) files, which you need to add to the project.
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Figure 6. Adding a New Source File to the Project, cont. Your project will consist of various

source (.c files) and header (.h) files, which you need to add to the project. Give them descriptive

names. The name, ‘hello_world.c’ is shown as the name of a source file in this example.

Figure 7 shows how the .cpp file appears in the Source Files folder in Solution Explorer and a tabbed window
appears where you type in the code.
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Figure 7. Source File Opened for Editing. Your project will consist of various source (.c files)
and header (.h) files, which you need to add to the project. Give them descriptive names. The
name, ‘hello_world.c’ is shown as the name of a source file in this example.
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Figure 8: Entering your program. Click in the newly created tab in Visual Studio in the main editing

window, and type a valid C++ program that uses the Standard C++ Library, or copy and paste one of the

sample programs.

For example, you can use the set::find (STL Samples) sample program in the Standard Template Library
Samples topics in the help.
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Figure 8. Entering C Code. You can start typing your program or cut-and-paste from some

other
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Figure 9: Compiling your program. On the Build menu, click Build Solution.

The Output window displays information about the compilation progress, such as the location of the build

log and a message that indicates the build status.
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Figure 9. Compiling Your Project. From the Build
menu,

click, ‘Build Solution’.
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9. Figure 10. Seeing how your program works. On the Debug menu, click ‘Start without Debugging’.

The console window will be displayed with your output and a prompt to ‘Press any key to continue...” If
you give the console window focus (click in it or on it), and press any key, the console window will close.
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Figure 10. Running Your Program. To see how your program runs, go to the Debug menu, and
select, ‘Start without Debugging’ (or Ctrl+F5). This will run your program and show the output
in a console window, which will stay open until you press any key (when the console has
window focus) to continue or select, ‘Stop Debugging’ from the Debug menu.

Debugging is actually extremely helpful, because it allows you to see how your program works,
line-by-line. Try debugging by first right-clicking in the gray margin at a statement you want the
program to stop at. You should see a big red dot. This is a ‘breakpoint’, which means that the
program will run up to the breakpoint and stop. Then go to the Debug menu, and select, “Start
Debugging’ (or F5). The program will run up to your breakpoint and stop.

It is very instructive to use the F11 key to go through your program line-by-line. Instead of
selecting “Start Debugging’, press the F11 key to step into your program. You can go line-by-
line through the operation of your program and look at the contents of variables, etc.

You can stop debugging by selecting that option on the Debug menu or pressing Shift+F5.
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